Print Page | Close Window

cruise control, 2003 sierra

Printed From: the12volt.com
Forum Name: Cruise Controls
Forum Discription: Cruise Control Settings, Tach Signal, VSS PPM(Vehicle Speed Signal Pulses Per Mile), Vacuum, Brake, etc.
URL: https://www.the12volt.com/installbay/forum_posts.asp?tid=97481
Printed Date: August 18, 2022 at 5:51 AM


Topic: cruise control, 2003 sierra

Posted By: gaiter
Subject: cruise control, 2003 sierra
Date Posted: September 27, 2007 at 7:13 AM

I have an 2003 Sierra base truck, did not come with cruise.  I have been told by more than one person/website that all I have to do to put cruise in the vehicle is to add the multi-function control arm.  I have done this, and the cruise does not work.  Vehicle connector has 12v on it, and set/resume/power on all produce proper outputs back to the vehicle connector.  I have checked all the fuses.  I reset the computer.  Is there anything I have overlooked?  Could there be something else missing?  Are there other fuses/relays other than what is in the two main fuse panels (one in the cab and one under the hood)?  Any help would be appreciated.



Replies:

Posted By: ranger svo
Date Posted: September 27, 2007 at 9:13 PM

Is your truck a V 6 or V8? The V8 is the only truck that the "only a handle" is needed. Nothing needs to be reset. It should work. Confirm that your truck has NO throttle cable. If a throttle cable is present, the handle won't work.

I have personally done near 50 of these trucks and not one problem.



-------------
The moving power of mathematical invention is not reasoning but imagination.
Augustus de Morgan





Posted By: Velocity Motors
Date Posted: September 27, 2007 at 9:40 PM
Does the 2003 have the driveby wire for the accelorator ? If so the just installing the arm should work as long as you have the proper arm.

-------------
Jeff
Velocity Custom Home Theater
Mobile Audio/Video Specialist
Morden, Manitoba CANADA




Posted By: gaiter
Date Posted: September 28, 2007 at 9:40 AM
Yes, it is a 4.8L, fly by wire - no cable.  The cruise still does not work.  I am out of ideas, I am ready to give up.  Is there anything else I can check?  Could the brake switch be faulty?  Where is the actuator?  Is it built into the module on the petal, or is it under the hood?  If anyone has a method of troubleshooting the system, I would really appreciate the guidance.




Posted By: CapSS92
Date Posted: October 01, 2007 at 4:04 AM
Dunno if it will help but try the forums at www.fullsizechevy.com .I know they have a lot of guys into the newer trucks. FYI.




Posted By: airandsound
Date Posted: October 18, 2007 at 12:33 PM
If all else fails, the local GM dealer can diagnois it in less than 30 minutes.




Posted By: NowYaKnow
Date Posted: October 18, 2007 at 9:35 PM
Check and make sure all your brake lights and 3rd brake light are good. Also the 4 pin connector on the handle is plugged in? I haven't seen many of those trucks that are prewired you usually have to extend the wires from the handle and connect at the rear of the junction block.

Mike




Posted By: j j perkins
Date Posted: October 26, 2007 at 12:55 PM
did you hard wire it or us a GM switch that plugs into GM harness ? 

-------------
jjperkins




Posted By: soultinter
Date Posted: February 04, 2008 at 4:09 PM
i think that if it is the work truck version, it is not prewiRED / installed like the normal silverado's





Print Page | Close Window