Print Page | Close Window

2004 yukon xl remote start

Printed From: the12volt.com
Forum Name: Car Security and Convenience
Forum Discription: Car Alarms, Keyless Entries, Remote Starters, Immobilizer Bypasses, Sensors, Door Locks, Window Modules, Heated Mirrors, Heated Seats, etc.
URL: https://www.the12volt.com/installbay/forum_posts.asp?tid=127540
Printed Date: January 20, 2022 at 5:30 AM


Topic: 2004 yukon xl remote start

Posted By: bpopilek
Subject: 2004 yukon xl remote start
Date Posted: June 03, 2011 at 11:33 PM

Hello, I just picked up this truck last week and just got around to installing a remote starter in it this evening. Normally I have not had too many issues with ones I have done in the past, but something isn't working quite right for me this time and I'm looking for some advice.

I purchased an Avital AviStart-4100 unit, and I was told that I needed the XPresskit XK01 unit to bypass the Passkey system to get it to start and to actuate the door locks.

At this point I have everything hooked up, but it's not working right. Since I didn't have the D2D cable, I connected everything using W2W instead. If I try to remote start the truck, it tries to then shuts right off and shows the anti-theft light. If I immediately start it again with the key and then remove the key, the truck will stay running off of the remote starter until I shut it off. This seems to be telling me that the bypass isn't working correctly.

I have tried following the directions to make sure that the XK01 is programmed correctly, but the LED status light never seems to do what the directions tell me it should be doing. I have no idea if it is correctly setup for a type 1 vehicle like mine is according to the directions. It will not let me do anything actually, even lock/unlock functionality is not working.

Does anyone have any suggestions? Is there a way to force the XK01 back to make sure it is setup for my vehicle? Will the XK01 even do what I am trying to do, or is there a better module that I should go get?

Any help is greatly appreciated. Thanks for reading!



-------------
There are 2 rules to life:
1. Don't sweat the small stuff.
2. It's all small stuff.



Replies:

Posted By: kreg357
Date Posted: June 04, 2011 at 5:02 AM

First, is the XK01 flashed with the AMDL firmware?  AMDL V6.0 is the current firmware for your vehicle. The only
way to tell for sure is with the XKLoader cable attached.  (Sometimes re-flashing the firmware seems to reset the
module and make it work.)

In the install guide ( Rev 20100609 ) follow the Type A diagram.  If you don't have / use the D2D cable, make all of the connections W2W
shown at the 10 Pin connector.  ( Pin 6 is optional. )  W2W mode is very reliable.

Follow the programming steps for W2W mode and at step 3, set the bypass module to Type 4 ( 4 blinks ) for your Yukon XL.
Not sure if re-flashing the module is the only way to reset this if it's already selected.

Lastly, do a search on this forum for "XK01".  There have been some recent posts concerning the XK01 and getting it
to program / work on various GM vehicles.

IMHO the XK01 is problematic.  I prefer to use iDatalink modules.  Any of these Solo series will duplicate the functions
of the XK01; the ADS ALSL GM, ADS DLSL GM or the ADS DLSL GM1.  They are very reliable, come pre-loaded and are much
easier to program.  Here is a link to iDatalink :  https://www.idatalink.com/support/helpdesk



-------------
Soldering is fun!




Posted By: beegbie
Date Posted: June 04, 2011 at 5:04 AM
Do you know what firmware is on the xk01?




Posted By: bpopilek
Date Posted: June 04, 2011 at 8:35 AM
As for the exact version of firmware on the XK01, you've got me. :-) All I can tell you is that it is flashed with AMDL software, but no idea of the version number. I see that there is a 6.00 firmware available to download for it. My question is how can I flash this unit without having an XKLoader? Can i Connect it manually to a USB or serial port? Thanks for the help!

-------------
There are 2 rules to life:
1. Don't sweat the small stuff.
2. It's all small stuff.




Posted By: kgerry
Date Posted: June 04, 2011 at 8:40 AM
XK01 comes shipped with AMDL , which is what you want.....  should be a very basic install... only 1 wire to connect in vehicle.... do all your W2W wiring on the bench (power, groung, status, locks, etc) and then take the harness to the truck and connect the violet to the OBD connector.... plug the module in, turn the key to IGN (run) and select type 4... when the LED flashes 4 times press and hold the programming button until the LED comes on solid,release programming button,  then start the vehicle and the LED will shut off....  works for me all the time and i use tons of XK01's....

-------------
Kevin Gerry
Certified Electronics Technician
MECP First Class Installer

Owner/Installer
Classic Car Audio
since 1979




Posted By: bpopilek
Date Posted: June 04, 2011 at 9:05 AM
It did seem simple enough, but for some reason I cannot get the XK01 to program correctly. Maybe there is something wrong with how I wired it all up?? Just in case, here is a list of the wires I used.

Avital --> XK01
Green (- Lock Output)   Green (-Lock Input)
Blue (- Unlock Output) Blue (-Unlock Input)
Light GREEN/ Black (Alarm disarm) Orange (Trunk or disarm input)
Blue (Status output) Brown (GWR Status Input)

XK01 Only
Red +12v
Black to ground
Violet to violet wire in pin 2 of the ODBII connector

Am I wrong or missing something? Thanks!

-------------
There are 2 rules to life:
1. Don't sweat the small stuff.
2. It's all small stuff.




Posted By: bpopilek
Date Posted: June 04, 2011 at 9:58 AM
Ok, I called the local car audio place and talked to the guy there. He had me bring the unit up there and we found out it was flashed with 6.00 firmware. I had him re-flash it and tried it again. This time it seemed to be showing me the correct flashes. I had to change it to a vehicle type 1 and viola it all seems to be working as advertised this time! Guess it was just a bad flash all along. Thanks for all the tips and advice!

-------------
There are 2 rules to life:
1. Don't sweat the small stuff.
2. It's all small stuff.




Posted By: bpopilek
Date Posted: June 04, 2011 at 10:00 AM
bpopilek wrote:

change it to a vehicle type 1


That should have said vehicle type 4. :-)

-------------
There are 2 rules to life:
1. Don't sweat the small stuff.
2. It's all small stuff.





Print Page | Close Window