Print Page | Close Window

remote start, 2010 jeep compass

Printed From: the12volt.com
Forum Name: Car Security and Convenience
Forum Discription: Car Alarms, Keyless Entries, Remote Starters, Immobilizer Bypasses, Sensors, Door Locks, Window Modules, Heated Mirrors, Heated Seats, etc.
URL: https://www.the12volt.com/installbay/forum_posts.asp?tid=135291
Printed Date: October 17, 2021 at 2:01 AM


Topic: remote start, 2010 jeep compass

Posted By: vlopddap
Subject: remote start, 2010 jeep compass
Date Posted: November 15, 2013 at 1:26 PM

I just finish to install a ProStart CT-3271 with an XpressKit XK09 bypass module. Both are DIRECTED products that are perfectly compatible. The XK09 bypass is loaded with CHRYSLER 3.02 firmware as well.

After installation I had no trouble programming the XK09 in less than 10 seconds... but the remote start module just don't do NOTHING...

When I tried to put the module in "PROGRAM MODE", neither by using the hood switch procedure or the program button in the unit. None do the trick. The +12V and ground are right however. I'm supposed to press button 4 SEC then parking light light on... but it never happen.

Here's my wiring diagram. My truck is a 2010 JEEP COMPASS which is a brand who support like 99% of D2D function on the module. Wiring connected are in YELLOW, other are not plugged. Sorry for the 2nd diagram, manual are in FRENCH.

Do you see something missing/suspicious in my wiring??

posted_image

posted_image



Replies:

Posted By: kreg357
Date Posted: November 15, 2013 at 2:14 PM

The only thing I see missing is the CT3271 Orange (+) Brake Input wire.  That function is not handled by the XK09 and needs to be hardwired to the vehicle.

Not a ProStart user, so can't help too much.



-------------
Soldering is fun!




Posted By: yellow_cake
Date Posted: November 15, 2013 at 2:54 PM
Does the prostart show any signs that it has power? When you plug it in, do you hear any relays clicking?
Also, where do you have the power and ground connected to for the prostart?




Posted By: vlopddap
Date Posted: November 15, 2013 at 3:27 PM
yellow_cake wrote:

Does the prostart show any signs that it has power? When you plug it in, do you hear any relays clicking?
Also, where do you have the power and ground connected to for the prostart?


Yes, I ear some relay clicking sound inside Prostart module.




Posted By: vlopddap
Date Posted: November 15, 2013 at 3:33 PM
kreg357 wrote:

The only thing I see missing is the CT3271 Orange (+) Brake Input wire.  That function is not handled by the XK09 and needs to be hardwired to the vehicle.


Not a ProStart user, so can't help too much.





In fact ProStart is another DIRECTED brand family, same as AstroStart, Viper, Clifford, etc. They are use the same base and components.

I admit it's just a single more wire to hook... maybe I'll not take a chance and connect it. But capture from XpressKit website :

posted_image




Posted By: yellow_cake
Date Posted: November 15, 2013 at 3:46 PM
Is the hood pin installed into a metal grounded surface?

Also, when you tried to enter programming mode using the small push button, did you have the Grey hood wire grounded? That wire must be at ground in order to enter programming mode with the push button.

This is how you would do it with the push button:
1) Ground the grey hood switch wire. 2) Press & hold button for 4 sec, release the button and parking lights will turn on for 1 sec. While lights are still on, press the button once & release right away. Now the parking lights should stay on for 20 seconds, in this time you can select a menu... Once you're done, return the grey hood switch wire back in it's place & close the hood.




Posted By: yellow_cake
Date Posted: November 15, 2013 at 3:51 PM
If the steps I showed you for the push button procedure works and the hood switch procedure doesn't work, then your hood switch is not proving ground while hood is open for what ever reason.




Posted By: yellow_cake
Date Posted: November 15, 2013 at 3:56 PM
You are right about the foot brake status. I think Kreg went on the fact that it wasn't shown as an optional W2W connection in the diagram (I made the same assumption).




Posted By: kreg357
Date Posted: November 15, 2013 at 4:02 PM

Sorry, you are correct on the Brake signal.  It is one of those "D2D only" signals and should be handled OK by the D2D harness connection.



-------------
Soldering is fun!




Posted By: vlopddap
Date Posted: November 17, 2013 at 9:14 PM
I finally give a call to DIRECTED technical support and the technician told me my remote start module is probably defective because all wire is okay and parking light SHOULD light up on any way... it's the basics, so if they don't light, an internal relay is DOA.

I finally change my mind and go the RSR easy way... I hook my XK09 module onto the ignition harness, clear it and reload it as standalone RSR and job done! My Jeep start with factory keyless remote in less than 30 minutes installation.

Thx guys for all your help.




Posted By: lucasoil4u
Date Posted: November 20, 2013 at 10:36 PM
You didn't hook up the neutral safety wire . Hook it up to ground and let us know what happens




Posted By: ronklo
Date Posted: September 28, 2015 at 10:26 PM

I installed a KX9 hard wired without the T harness as well and it didn't work at first.  I used those tap connectors that snap onto a wire, and you add another wire along side.  

The connectors I used were too big for the gauge of wires used on the ignition harness, so they did not make connection.  After replacing with the proper size connectors, everything

worked fine.  The range with the factory key is not very good, so I'm working on using an old cell phone with a $5/month data plan that is set to trigger a Arduino controller when I call

the cell phone (which doen'st use any data), and it will press the lock button 3 times on a spare key hidden in the car.  I'll disable the horn for the 1st 2 button presses, or maybe all 3

so it doesn't annoy the neighbors early in the morning, and I'm also going to use a bluetooth key finder, to trigger the unlock on the same spare key, from my cell phone to unlock the jeep

in case I leave my keys inside....!!!   now if only I had time to build it.!!






Print Page | Close Window