Print Page | Close Window

06 ion no remote start after gm recall

Printed From: the12volt.com
Forum Name: Car Security and Convenience
Forum Discription: Car Alarms, Keyless Entries, Remote Starters, Immobilizer Bypasses, Sensors, Door Locks, Window Modules, Heated Mirrors, Heated Seats, etc.
URL: https://www.the12volt.com/installbay/forum_posts.asp?tid=137371
Printed Date: October 06, 2022 at 3:58 PM


Topic: 06 ion no remote start after gm recall

Posted By: 83trekker
Subject: 06 ion no remote start after gm recall
Date Posted: October 03, 2014 at 12:06 PM

So GM did the ignition switch recall on my 06 Ion, Gm then said I have to reprogram the remotes for the remote starter to work, its a compustar and I programmed the remotes as per compustar. The door locks all work. when i take the car out of valet mode and try the remote starter the Passlock kicks in and locks me out until I put it in valet mode and wait 10 minutes. anybody been able to fix this after the ignition switch recall? Any suggestions? Worked perfect till gm put in a new ignition switch. Thanks



Replies:

Posted By: metz35
Date Posted: October 03, 2014 at 12:58 PM
relearn the bypass.




Posted By: pentavolvo
Date Posted: October 03, 2014 at 1:29 PM
metz35 wrote:

relearn the bypass.


X2. Been doing a bunch of these lately




Posted By: 83trekker
Date Posted: October 03, 2014 at 2:04 PM
Ok the bypass for the compustar do you mean? And if so do you know how I would do that?

I really appreciated this!!




Posted By: sparkie
Date Posted: October 03, 2014 at 2:40 PM
The bypass module that interfaces with the Passlock system needs to relearn the new ignition switch values. It is separate from the Compustar remote starter. You have to determine which one is installed and then reprogram it.

-------------
sparky




Posted By: 83trekker
Date Posted: October 03, 2014 at 2:42 PM
Sorry this is new to me, so is this GM module in the car or a separate module from the remote start install?

How do I program it?




Posted By: cvsct698
Date Posted: October 03, 2014 at 5:37 PM
Depends on the remote start you have. If you have something like a CS -600 it will definitely be a separate box. It is possible, but less likely, that it may be integrated in the remote start itself. This could be the case if you have a CM-6000 or similar control module. What model remote start do you have?




Posted By: auto enhancers
Date Posted: October 04, 2014 at 11:51 AM
I would suggest taking it to a remote start installation facility, It may be as easy as relearning the bypass but I have seen where some GM techs have cut the wires to the passloc system meaning they will be needing reconnected.




Posted By: 83trekker
Date Posted: October 06, 2014 at 8:49 AM
Most of the places wont touch it unless they are the ones that install it, bought the car with it already installed and don't know where it was installed, all they do is offer to sell you a new one. So tonight I will see what model of compustar I have and post it and hope fully somebody can tell me or lead me to a manual for the relearn, thanks all cant afford to buy a new one and its getting cold here.




Posted By: auto enhancers
Date Posted: October 06, 2014 at 9:16 AM
Where are you located at, I know shops all over that will work on the system as long as it is installed properly




Posted By: 83trekker
Date Posted: October 06, 2014 at 9:46 AM
I am in Calgary Alberta Canada




Posted By: 83trekker
Date Posted: October 10, 2014 at 9:07 AM
OK so the bypass module is ADS DL (16). I download a pdf of the install sheet. I did what it said and I got the car because its a manual to keep running after I turn the key off to set the remote start. So I tried to remote start the car and didn't work, it just kept trying to start but the car never turned over.

So in the install instructions it lists 2 ways to program the car but I am unsure of which one relates to the 06 ion. I tried both ways but no luck and I couldn't get the car to ever go back to it running with the key out so its set for next start.

None of the fuses or wires are cut or taken off by GM when they did the recall.

When reading the instructions to program the bypass 1 green blinking light means Data Mode 2 quick blinking lights means standard hard wire mode, which one should I be using?

Also it shows programming for 1, 3 and 4 module programming procedure. and a different one for Type 2 module programming, would anybody know which one my Ion would need, it doesn't say specifics on any of this.

Anything else I might be missing? I am very close to getting this working, so any tips or help would be greatly appreciated!




Posted By: lucasoil4u
Date Posted: October 10, 2014 at 11:00 AM
you have to see how it is installed in the car, I would recommend taking it to a local shop and have them take care of this for you. Very simple and they can just get it done with knowing 100% whats happeneing.




Posted By: catback
Date Posted: October 10, 2014 at 11:10 AM
83trekker wrote:

OK so the bypass module is ADS DL (16). I download a pdf of the install sheet. I did what it said and I got the car because its a manual to keep running after I turn the key off to set the remote start. So I tried to remote start the car and didn't work, it just kept trying to start but the car never turned over.

So in the install instructions it lists 2 ways to program the car but I am unsure of which one relates to the 06 ion. I tried both ways but no luck and I couldn't get the car to ever go back to it running with the key out so its set for next start.

None of the fuses or wires are cut or taken off by GM when they did the recall.

When reading the instructions to program the bypass 1 green blinking light means Data Mode 2 quick blinking lights means standard hard wire mode, which one should I be using?

Also it shows programming for 1, 3 and 4 module programming procedure. and a different one for Type 2 module programming, would anybody know which one my Ion would need, it doesn't say specifics on any of this.

Anything else I might be missing? I am very close to getting this working, so any tips or help would be greatly appreciated!


Data or hardwire mode depends on how the bypass is connected to the compustar. Looking at the diagram in the install guide and at the bypass and compustar you will be able to discern how the two are connected/wired together.

The ion is a type 1 installation thus you'll use the type 1 programming instructions.

Once the mode and programming is done correctly and is successful if the vehicle is still problematic with remote starts you'll need to dive into checking the wiring.




Posted By: 83trekker
Date Posted: October 10, 2014 at 12:11 PM
Thanks all ill try tonight




Posted By: 83trekker
Date Posted: October 10, 2014 at 8:51 PM
OK so i got it all working and everythings good BUT now when you take the key out so the car can stay running it wont do it. I can get it to work somje how and its perfect, remote start, get in the car and drive then it wont go into reservation mode again, i dont get it why wont it go in after? I make sure its in neutral, parking brake on dont touch the brake, any ideas?




Posted By: 83trekker
Date Posted: October 10, 2014 at 9:16 PM
Ok so now if I reprogram the remote it will always go into reservation mode no problem. Also if its in reservation mode and I DON'T remote start the car with the remote it will always go into reservation mode, bbut as soon as I remote start the car it no longer goes into reservation mode any ideas?




Posted By: 83trekker
Date Posted: October 13, 2014 at 8:10 PM
anybody have any ideas im so close now? thanks




Posted By: catback
Date Posted: October 15, 2014 at 3:10 AM
It really shouldn't be any more difficult than reprogramming the bypass after the ignition switch was changed. But a shot in the dark, relearn the tach.




Posted By: 83trekker
Date Posted: October 15, 2014 at 8:54 AM
I did do that and same, but I found that before turning the car off foot on the brake and hold the start button for 2.5 secs which I think I the tach learn and it stays in reservation mode all the time then. at least it works.

Lady at work has a Ion same thing recall doesn't work, went to where she had it installed and they said 300 bucks to fix, went some where else and they said they wont touch it cause they didn't install it. So I reprogrammed her bypass and it works perfect now and hers is a automatic. She was very happy and took me 5 minutes to do. At least I have learned something here thanks to all of you guys!




Posted By: catback
Date Posted: October 15, 2014 at 12:12 PM
83trekker wrote:

I did do that and same, but I found that before turning the car off foot on the brake and hold the start button for 2.5 secs which I think I the tach learn and it stays in reservation mode all the time then. at least it works.

Lady at work has a Ion same thing recall doesn't work, went to where she had it installed and they said 300 bucks to fix, went some where else and they said they wont touch it cause they didn't install it. So I reprogrammed her bypass and it works perfect now and hers is a automatic. She was very happy and took me 5 minutes to do. At least I have learned something here thanks to all of you guys!


Does it successfully learn the tach? Does the parking lights flash and/or siren chirp? If so how many times?




Posted By: 83trekker
Date Posted: October 15, 2014 at 12:28 PM
Its clicks once, and that's it and then you take the key out and it stays in reservation mode.




Posted By: 83trekker
Date Posted: November 05, 2014 at 7:22 PM
OK so this has been working now for a while, BUT now when it goes into reservation mode the engine wont crank it just sits there locks the doors and the lights stay on and thats it, any ideas?




Posted By: catback
Date Posted: November 06, 2014 at 7:53 AM
I'm confused, the engine is supposed to be already running when entering reservation mode so why would we want it to crank and grind the starter?




Posted By: 83trekker
Date Posted: November 06, 2014 at 12:16 PM
catback wrote:

I'm confused, the engine is supposed to be already running when entering reservation mode so why would we want it to crank and grind the starter?


No, it goes into reservation mode, get out car shuts down doors lock all good, then when I try to remote the car the lights turn on, doors relock, fuel pump primes, but it will not crank and it just sits there with the lights on but that's it.

I relearned tach again, and redid the bypass. Everything seems to be fine besides the no start




Posted By: 83trekker
Date Posted: November 08, 2014 at 5:27 PM
Anybody have any ideas? I talked to a shop but they don't intsall they won't touch it but they will sell me a new one! Gonna be minus 20 next week help!




Posted By: 83trekker
Date Posted: September 03, 2016 at 11:47 PM
OK so its been a while since i started this thread and the car starter has been working fine. But now its doing the same thing.

So i relearned the programming procedure and everything works again, goes into reservation mode no problem.

BUT if you dont set the reservation mode properly everytime(such as you have your foot on the brake when you turn the key off) it looses it and wont go back into reservation mode again,even after restarting the car and setting the rerservation mode properly, unless i relearn the whole programing procedure again and then it works perfect as long as you set it properly everytime.

Its driving me crazy can anybody shed some light on this??




Posted By: 83trekker
Date Posted: September 03, 2016 at 11:49 PM
Also i checked every connection made on this and all wires are still soldered fine and no broken wires or loose connections.




Posted By: lurch228
Date Posted: September 04, 2016 at 1:12 AM
Have you had the ADS-DL-GM4 Firmware checked to make sure it the most current version 3.9 released on June 19.2013

Older versions were:

Version 3.8 | Revision Date: 2012-11-16 00:00:00

Version 3.7 | Revision Date: 2012-10-19 00:00:00




Posted By: lurch228
Date Posted: September 04, 2016 at 1:31 AM
Also when you set reservation mode does opening the door cancel the reservation mode. If not then the door trigger isn't hooked up or wired correctly, The vehicle door triggers may be functioning improperly, which means no reset.




Posted By: 83trekker
Date Posted: September 04, 2016 at 1:11 PM
I'm an not sure of the firmware on how to check or change it. The place that installed is now out of buisness and no shop will touch it they only want to install a new $550 starter.

In reservation mode the car is running you op3n the door and once you close the door it shuts down the engine and sets it self up for remote start which works fine as long as you can get the car in res mode before exiting it.




Posted By: lurch228
Date Posted: September 04, 2016 at 4:39 PM
You need the flasher interface and a account login to flash modules.

Don't ask them to touch the car just ask them to flash the module. Then take out the module and hand it to them to flash. They don't need any of the wires to flash it, just the module itself!




Posted By: 83trekker
Date Posted: September 04, 2016 at 5:18 PM
Ok I can.try that? Do.you think it could be the firmware if it used to work perfect before untill I had to relearn it because of gm ignition recall.




Posted By: lurch228
Date Posted: September 04, 2016 at 5:37 PM
Firmware's are updated to fix stability and function issues so it's possible that this is a issue. Once you have the latest firmware if the problem persists you can try and contact the iDatalink tech support and explain that your original installer has gone out of business and they may help. But if you don't have the latest firmware they will tell you to upgrade the fimrware first as they don't support outdated firmware.




Posted By: 83trekker
Date Posted: September 05, 2016 at 12:28 PM
So driving alot around town a little bit on the highway get home and it goes into reservation mode, this thing has a mind of its own.




Posted By: lurch228
Date Posted: September 05, 2016 at 1:23 PM
Eliminate the bypass freaking out due to firmware issues, And then you'll be that much closer to finding the issue.




Posted By: 83trekker
Date Posted: September 05, 2016 at 1:44 PM
Yes I'm gonna call around some shops and see who will flash the firmware for me.




Posted By: lurch228
Date Posted: September 05, 2016 at 3:29 PM
Get the firmware flashed to the latest if you still have issues post back and also try tech support for the module.




Posted By: 83trekker
Date Posted: September 05, 2016 at 3:47 PM
Thanks lurch I appreciated it




Posted By: lurch228
Date Posted: September 05, 2016 at 5:41 PM
No problem.




Posted By: bogucki
Date Posted: September 27, 2016 at 4:39 PM
hey
I'm in calgary and a installer , if you still need some one to update the ads bypass module i have the program cable and ads account and can do that for you


-------------
BOGUCKIALEX




Posted By: 83trekker
Date Posted: September 27, 2016 at 4:43 PM
Sorry for got to update this it was a bad brain , replace it and works great.

I will keep you in mind if i ever have a problem with any of my 3 car starters, you want to give me your email or something?

Thanks!




Posted By: bogucki
Date Posted: September 27, 2016 at 4:45 PM
sure
its bogucki@telus.net

-------------
BOGUCKIALEX




Posted By: 83trekker
Date Posted: September 27, 2016 at 4:47 PM
Cool thanks!





Print Page | Close Window