the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
icon

clarion vrx755 / amp grd error


Post ReplyPost New Topic
< Prev Topic Next Topic >
Woody_pugh 
Member - Posts: 5
Member spacespace
Joined: May 09, 2005
Location: United States
Posted: May 09, 2005 at 4:18 PM / IP Logged  
My roommate and I are currently stumped with this message;  "amp grd".  We just installed the unit...it turns on and operates fine.  Sound comes out for 2 secs and turns off.  The unit displays "amp grd" and no one on God's green earth has been able to explain what this means.  The most logical thought is that too much power is going into the unit....??
Woody
Chad7n7 
Silver - Posts: 408
Silver spacespace
Joined: March 09, 2004
Location: United States
Posted: May 09, 2005 at 5:16 PM / IP Logged  
"amplifier ground" is the message, but what kind of unit, model number, type of vehicle, are we talking about, that way we can try to narrow down the problem.  Also what is connected to this "unit"
Woody_pugh 
Member - Posts: 5
Member spacespace
Joined: May 09, 2005
Location: United States
Posted: May 09, 2005 at 5:18 PM / IP Logged  
2002 chevy s-10 ZR-2, Clarion VRX755VD
Woody
Chad7n7 
Silver - Posts: 408
Silver spacespace
Joined: March 09, 2004
Location: United States
Posted: May 09, 2005 at 5:21 PM / IP Logged  

I am assuming you used an aftermarket harness??? Does he still have stock speakers connected to this HU??

Woody_pugh 
Member - Posts: 5
Member spacespace
Joined: May 09, 2005
Location: United States
Posted: May 09, 2005 at 5:24 PM / IP Logged  
yes....there was a previously installed pioneer unit that was removed.  stock speakers are still in place unfortunately.
Woody
Woody_pugh 
Member - Posts: 5
Member spacespace
Joined: May 09, 2005
Location: United States
Posted: May 09, 2005 at 5:39 PM / IP Logged  
the deck is installed with the previous wiring harness from the pioneer. we just spliced the new harness with that one.  there is an mtx amp with three 10 in mtx comp subs all were fine before the install
Woody
Chad7n7 
Silver - Posts: 408
Silver spacespace
Joined: March 09, 2004
Location: United States
Posted: May 09, 2005 at 5:51 PM / IP Logged  

Try checking your ground connections, if they are good, then try regrounding tthe HU to some bare metal in the dash, you could have a problem with the factory ground. 

Woody_pugh 
Member - Posts: 5
Member spacespace
Joined: May 09, 2005
Location: United States
Posted: May 09, 2005 at 5:57 PM / IP Logged  
the HU turns on and everything seems to work.  the sound is the main problem.  you hear it at first and then it shuts off...counter shows it keeps playing.
Woody
Chad7n7 
Silver - Posts: 408
Silver spacespace
Joined: March 09, 2004
Location: United States
Posted: May 09, 2005 at 6:17 PM / IP Logged  

ahh, try looking at your speaker connections, sounds you have a wire grounding,try disconnecting all speakers and see if it does it. If not, try connecting one at a time, see if you can single out the speaker thats causing the problem, and work from there, the easiest solution may be running a new wire from the HU to the speaker, its usually not fun tracing the factory wire for a knick. Also check to make sure the speaker terminals are not touching any metal, which is unlikely, because they are factory speakers.

04mdx4sq 
Copper - Posts: 111
Copper spacespace
Joined: November 01, 2004
Location: United States
Posted: May 10, 2005 at 8:58 AM / IP Logged  
That's where to look, the message you are getting is "amp guard". This is the mesage it will display when a short in a speaker wire or speaker with low impedence is hooked to the internal amp and sends it into protect mode, shutting down the amplifier section while the rest of the unit continues to work.
04 MDX - Clarion DRZ9255 / MB Quart QAA4250 / MB Quart QSD216 / Orion Concept 97.2 / JL Audio 10w6v2
91 GMC Syclone - Delco tape deck
90 Syclone powered 2wd S10 (for sale) - Pyle CD / Fosgate 4x6
Page of 2

  Printable version Printable version Post ReplyPost New Topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

  •  
Search the12volt.com
Follow the12volt.com Follow the12volt.com on Facebook
Wednesday, January 26, 2022 • Copyright © 1999-2022 the12volt.com, All Rights Reserved Privacy Policy & Use of Cookies
Disclaimer: *All information on this site ( the12volt.com ) is provided "as is" without any warranty of any kind, either expressed or implied, including but not limited to fitness for a particular use. Any user assumes the entire risk as to the accuracy and use of this information. Please verify all wire colors and diagrams before applying any information.

Secured by Sectigo
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
Support the12volt.com
Top
the12volt.com spacer
the12volt.com spacer