the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
icon

water leaking in grand am


Post ReplyPost New Topic
< Prev Topic Next Topic >
supradude 
Silver - Posts: 915
Silver spacespace
Joined: September 21, 2004
Location: South Carolina, United States
Posted: May 24, 2009 at 7:25 PM / IP Logged  
I'm going crazy trying to find where the water is coming in when it rains on my 96 Grand Am GT. It all started when I had to get the windshield replaced a few years ago. Naturally I figured it was that they made a mistake when they put the new one in. Then I had another company replace it again, with the same results. Now I really doubt that it is from the windshield, but I can't seem to find it. I know this is a pretty popular car so I was hoping that I could get some feedback from somebody that has had this same type problem. It gets on the floor on just the driver's side, both front and back, which makes me think it could be from the rubber around the driver's door, but I have let water from a hose run on it with no leak. I'm just looking for advice from somebody that might have had this happen, not the usual responses like run water on it and look for it, because I've tried that.
'85 Toy
tommy... 
Gold - Posts: 1,901
Gold spacespace
Joined: December 10, 2004
Location: United States
Posted: May 25, 2009 at 2:05 PM / IP Logged  
Just throwing it out there ...Have seen a cpl cars that just pushed a grommet through to run a power wire and left a big gaping hole...Grommet in door jam...How long after replacing windshield did water start forming...Not a windshield installer,but it could have a "DOUBLE GASKET" somewhere.If running water over top of car is not re-creating it...Maybe it is coming from underneath...?
M.E.C.P & First-Class
Go slow and drink lots of water...Procrastinators' Unite...Tomorrow!
supradude 
Silver - Posts: 915
Silver spacespace
Joined: September 21, 2004
Location: South Carolina, United States
Posted: May 26, 2009 at 9:35 AM / IP Logged  
Thanks, tommy... I ran the power wire, and I even put some silicone around the grommet since there was water getting into the car. I thought that maybe that was the problem, even though I couldn't see how it could be. I've never had a single car leak around the power wire before, and I don't think that is the problem. The leak started shortly after the windshield was installed. I don;t remember exactly how long. I did get a tip from somebody that it could the drainage port partially stopped with leaves and trash causing it to overflow into the floorboard, but I've never heard of that.
'85 Toy
howie ll 
Pot Metal - Posts: 16,466
Pot Metal spacespace
Joined: January 09, 2007
Location: United Kingdom
Posted: August 02, 2009 at 8:21 AM / IP Logged  
Leaves blocking the drainage followed by grommets left out followed by sun-roof drainage tubes blocked  followed by non-standard speakers incorrectly fitted are the most common cause
vibrationcustum 
Copper - Posts: 171
Copper spacespace
Joined: April 05, 2009
Location: Michigan, United States
Posted: August 02, 2009 at 9:20 AM / IP Logged  
Just make sure that it is not your heater core, you might thank that is does it while it rains but it just might leak and you just notice it with the rain. With the heater core I have seen it leak on driver and passenger side. When sweeping up the water see what color it is. If it is green or like a light brown and have a bad smell to it. I would check what HOWIE said as well very common and check and see if there is anything blocking under the grate where the windshield wiper motor is. If that had things in it then the water will not drain right.
Can't be loud then don't have it.
(power acoustik system)
Head unit- TID-896 7" TOUCHSCREEN
ovn1-5500d 09 and another one coming soon
4-12" mofos 12ft3 box to 40hz (wall)
2 batterys, 1 power
supradude 
Silver - Posts: 915
Silver spacespace
Joined: September 21, 2004
Location: South Carolina, United States
Posted: August 02, 2009 at 7:46 PM / IP Logged  
Thanks, I guess I'll have to pull the black plastic cover that fits over the wiper motors. I guess the drain ports are there?
'85 Toy
vibrationcustum 
Copper - Posts: 171
Copper spacespace
Joined: April 05, 2009
Location: Michigan, United States
Posted: August 03, 2009 at 2:43 AM / IP Logged  
yeap they run down the side next to the finder
Can't be loud then don't have it.
(power acoustik system)
Head unit- TID-896 7" TOUCHSCREEN
ovn1-5500d 09 and another one coming soon
4-12" mofos 12ft3 box to 40hz (wall)
2 batterys, 1 power
supradude 
Silver - Posts: 915
Silver spacespace
Joined: September 21, 2004
Location: South Carolina, United States
Posted: August 03, 2009 at 5:20 AM / IP Logged  
Thanks a lot!!
'85 Toy

Sorry, you can NOT post a reply.
This topic is closed.

  Printable version Printable version Post ReplyPost New Topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

  •  
Search the12volt.com
Follow the12volt.com Follow the12volt.com on Facebook
Tuesday, December 7, 2021 • Copyright © 1999-2021 the12volt.com, All Rights Reserved Privacy Policy & Use of Cookies
Disclaimer: *All information on this site ( the12volt.com ) is provided "as is" without any warranty of any kind, either expressed or implied, including but not limited to fitness for a particular use. Any user assumes the entire risk as to the accuracy and use of this information. Please verify all wire colors and diagrams before applying any information.

Secured by Sectigo
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
Support the12volt.com
Top
the12volt.com spacer
the12volt.com spacer