the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
icon

amp, speaker matching


Post ReplyPost New Topic
< Prev Topic Next Topic >
will987 
Member - Posts: 2
Member spacespace
Joined: January 27, 2015
Posted: January 27, 2015 at 11:33 AM / IP Logged  
Hi everyone, this is my first post, I hope I can be steered in the right direction.
I havn't put a mobile system together in quite some time and think something's not adding up.
The setup: Plok audio DB6501's, Alpine SPR-69's JVC Arsenal reciever.
Amp: Soundstream Picasso P4.800.
Ive done multiple component upgrades in my life, but have never amplified them externally.
The components are listed at 100watt rms/300 peak per speaker, all 4 ohm. The amp is listed as 2 ohm stereo/ 4 ohm bridged but also lists a 125x4@4ohm rms output. I have everything wired for stereo on all four channels(+ to +/- to -)
Everything sounded great for about a week, and now its falling downhill. I think the tweeters are dying and the alpine's never sounded correct.
I found the receivers max vol with the amp bottomed out, then raised everything to the middle, gains/ sensitivities. From what i understand thats about 60 watt rms per channel, well within the safe zone of my components as i understand.
If i turn it up to a fair volume, its still plays, just feels muddy at any volume. The polks used to sound really good with the hpf around 140hz, crystal clear highs and snare hits that made me flinch. I thought my settings were a decent amount of power for breaking in everything, but now it sounds like a set of stock 95 camry speakers that can get 3 times as loud. Im at a loss on this one.
I guess the question is: Could I have cooked all 4 speakers in 2 weeks with it setup this way?
Any professional opinions on what the drop in clarity came from?
Can you run an amp listed as 2ohm stereo/4ohm bridged as 4 ohm stereo safely?
will987 
Member - Posts: 2
Member spacespace
Joined: January 27, 2015
Posted: January 27, 2015 at 11:37 AM / IP Logged  
Edit: Here is a link to the amp's manufacturer:
http://soundstream.com/store/car-audio/amplifiers/picasso/p4-800.html
sirhutson 
Member - Posts: 30
Member spacespace
Joined: January 29, 2015
Location: Texas, United States
Posted: January 29, 2015 at 3:01 PM / IP Logged  
Do you listen to this with the engine off? What kind of power wire and RCA's are you using? Do you have any pictures I could look at?
Hutson-

Sorry, you can NOT post a reply.
This topic is closed.

  Printable version Printable version Post ReplyPost New Topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

  •  
Search the12volt.com
Follow the12volt.com Follow the12volt.com on Facebook
Saturday, February 24, 2024 • Copyright © 1999-2024 the12volt.com, All Rights Reserved Privacy Policy & Use of Cookies
Disclaimer: *All information on this site ( the12volt.com ) is provided "as is" without any warranty of any kind, either expressed or implied, including but not limited to fitness for a particular use. Any user assumes the entire risk as to the accuracy and use of this information. Please verify all wire colors and diagrams before applying any information.

Secured by Sectigo
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
Support the12volt.com
Top
the12volt.com spacer
the12volt.com spacer