the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
icon

Added 2nd 2 Way Remote, Lock/Unlock Broken, Python 991


Post ReplyPost New Topic
< Prev Topic Next Topic >
lancef51 
Member - Posts: 2
Member spacespace
Joined: May 09, 2024
Location: Minnesota, United States
Posted: May 10, 2024 at 9:42 PM / IP Logged Link to Post Post Reply Quote lancef51
I programmed a new 2way remote to a Python 991 remote starter/security unit and now the door lock/unlock doesn't work. The original remote is a 7752P and the new one is a 7752V (the 7752P is no longer available). I've tried removing all the remotes from memory using the ZAP Bitwriter function and at one point I got the original remote working correctly but the lock/unlock stopped working again when I added the new remote.
I'm not sure how I got it working again with just the original remote but haven't been able to duplicate that yet. I was playing around with a few settings like door, hood, and trunk input polarity using the Bitwriter and writing the file to remote 0 or 1. At this time all of the options are set to the factory default but I also tried selecting Automatic vs Manual transmission.
I also tried switching the remote's "System Type" but it looks like all that does is change the text that shows up when you press Lock or Unlock.
This car starter/security controller is being used to remotely control a piece of equipment (not installed in a car). The only functions needed are the outputs for lock, unlock, trunk, and Aux1. Those outputs along with the status, neutral safety, siren, parking light, and armed outputs are connected to low current inputs on a PLC and the ignition, door(-), and trunk switch inputs are fed by outputs from the same PLC. The code in the PLC sequences these outputs as required to activate and deactivate the remote programming function when necessary.
Now when I press the LOCK button on the remote the system appears to go into the Armed state (the armed output goes active and the blue LED on the "Control Center" blinks continuously at about 1Hz. When I press the UNLOCK button the armed output goes inactive and the LED stops blinking. Neither the lock or unlock outputs The indications on the remotes appear to be normal for either or both remotes if they are programmed into the system.
All of this has been working for several years without any problems until one of the original 7752P remotes died and I tried to replace it with a 7752V. Given that the problem started both immediately after programming the new remote into the system, I really doubt that this is a hardware malfunction.
I'm looking for any advice on how to get this working again.
-lance
silvercivicsir 
Copper - Posts: 409
Copper spacespace
Joined: November 21, 2003
Posted: May 13, 2024 at 7:09 PM / IP Logged Link to Post Post Reply Quote silvercivicsir
have you tried testing with a multi meter the unlock/lock outputs on the viper brain?
lancef51 
Member - Posts: 2
Member spacespace
Joined: May 09, 2024
Location: Minnesota, United States
Posted: May 14, 2024 at 8:02 AM / IP Logged Link to Post Post Reply Quote lancef51
Yeah, I should have checked the outputs as they were good. I was convinced that the problem was in the controller since it started when I paired the new remote but that was a bad assumption. The system includes a "radio enable" switch connected to another input on the PLC that disables the lock and unlock inputs inside the PLC and there was a bad crimp on one of the wires on that switch. The PLC program requires that that this switch be turned off (open) when paring a remote and apparently when I switched it off the poor contact in the bad crimp opened leaving the PLC to ignore the lock and unlock inputs. I should know better than to make assumptions and then fail to validate them, having been involved in troubleshooting electronics for most of my professional life, guess I'm getting old.
Each PLC input has a LED showing it's status but when I was initially trying to figure this out I didn't have the documentation showing which input was which. Once I got that out I quickly discovered that the lock and unlock inputs were working properly and the radio enable input was off. Wiggling the wires on the switch with the switch on would intermittently turn that input on. I recrimped the terminal and everything is working now.
-lance

If you wish to post a reply to this topic, you must first login.
If you are not already registered, you must first register.

  Printable version Printable version Post ReplyPost New Topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

  •  
Search the12volt.com
Follow the12volt.com Follow the12volt.com on Facebook
Wednesday, May 22, 2024 • Copyright © 1999-2024 the12volt.com, All Rights Reserved Privacy Policy & Use of Cookies
Disclaimer: *All information on this site ( the12volt.com ) is provided "as is" without any warranty of any kind, either expressed or implied, including but not limited to fitness for a particular use. Any user assumes the entire risk as to the accuracy and use of this information. Please verify all wire colors and diagrams before applying any information.

Secured by Sectigo
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
Support the12volt.com
Top
the12volt.com spacer
the12volt.com spacer