the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
icon

Amp doesn’t get power when grounded


Post ReplyPost New Topic
< Prev Topic Next Topic >
hatkoff 
Member - Posts: 4
Member spacespace
Joined: September 09, 2006
Posted: September 09, 2006 at 4:54 PM / IP Logged  
Yesterday I jumped started someone and my subs stopped working. I check my fuses. I have power to the amp. But its red which means "protect" and green means good to go. But when I ground it, it doesn't get power at all :/
DYohn 
Moderator - Posts: 10,741
Moderator spaceThis member has made a donation to the12volt.com. Click here for more info.spaceThis member has been recognized as an authority in Electrical Theory. Click here for more info.spaceThis member has been recognized as an authority in Mobile Audio and Video. Click here for more info.spacespace
Joined: April 22, 2003
Location: Arizona, United States
Posted: September 09, 2006 at 6:40 PM / IP Logged  

What does "when I ground it" mean?

Disconnect your subs.  If the amp is still in protect after you turn it on, your amp is probably blown.

Support the12volt.com
cloak559 
Copper - Posts: 215
Copper spacespace
Joined: July 14, 2006
Location: United States
Posted: September 09, 2006 at 6:54 PM / IP Logged  
hatkoff wrote:
But when I ground it, it doesn't get power at all :/
Are you saying that at some point you ran your amp without grounding it?
'89 Mercedes-Benz 300E
Pioneer DEH-5900UB
(2)RE Audio SX 10"s
(1)US Amps MD3D
3ft^3 @ 37Hz
Blowing up in a car accident doesnt worry me, as long as I'm putting out some major dB's when I die...
hatkoff 
Member - Posts: 4
Member spacespace
Joined: September 09, 2006
Posted: September 10, 2006 at 2:18 AM / IP Logged  
No, it was working but they stopped working for some reason... And it wasnt getting power. So I took it a part and put it together and before i grounded it, it had power. but when i ground it, it doesnt have power
DYohn 
Moderator - Posts: 10,741
Moderator spaceThis member has made a donation to the12volt.com. Click here for more info.spaceThis member has been recognized as an authority in Electrical Theory. Click here for more info.spaceThis member has been recognized as an authority in Mobile Audio and Video. Click here for more info.spacespace
Joined: April 22, 2003
Location: Arizona, United States
Posted: September 10, 2006 at 9:48 AM / IP Logged  
First of all, NEVER connect power before ground, and you should not be working on power leads unless they are disconnected from the battery.  I suggest you need to go to a local car audio shop and pay for a proper installation and to get your amp tested.
Support the12volt.com
hatkoff 
Member - Posts: 4
Member spacespace
Joined: September 09, 2006
Posted: September 10, 2006 at 2:57 PM / IP Logged  
its only get power when its not grounded but its on "protect" mode. but when its grounded it doesnt get power
DYohn 
Moderator - Posts: 10,741
Moderator spaceThis member has made a donation to the12volt.com. Click here for more info.spaceThis member has been recognized as an authority in Electrical Theory. Click here for more info.spaceThis member has been recognized as an authority in Mobile Audio and Video. Click here for more info.spacespace
Joined: April 22, 2003
Location: Arizona, United States
Posted: September 10, 2006 at 3:44 PM / IP Logged  

Like I said:

DYohn wrote:
First of all, NEVER connect power before ground, and you should not be working on power leads unless they are disconnected from the battery.  I suggest you need to go to a local car audio shop and pay for a proper installation and to get your amp tested.

Support the12volt.com
hatkoff 
Member - Posts: 4
Member spacespace
Joined: September 09, 2006
Posted: September 10, 2006 at 5:30 PM / IP Logged  
Well, until then maybe someone else will be able to help me.
forbidden 
Platinum - Posts: 5,352
Platinum spaceThis member has made a donation to the12volt.com. Click here for more info.spaceThis member has been recognized as an authority in Mobile Audio and Video. Click here for more info.spacespace
Joined: November 01, 2003
Location: Alberta, Canada
Posted: September 10, 2006 at 6:37 PM / IP Logged  
Nope, take it to a install shop before your short cuts and voodoo make the matter worse than it is.
Top Secret, I can tell you but then my wife will kill me.

Sorry, you can NOT post a reply.
This topic is closed.

  Printable version Printable version Post ReplyPost New Topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

  •  
Search the12volt.com
Follow the12volt.com Follow the12volt.com on Facebook
Sunday, April 21, 2024 • Copyright © 1999-2024 the12volt.com, All Rights Reserved Privacy Policy & Use of Cookies
Disclaimer: *All information on this site ( the12volt.com ) is provided "as is" without any warranty of any kind, either expressed or implied, including but not limited to fitness for a particular use. Any user assumes the entire risk as to the accuracy and use of this information. Please verify all wire colors and diagrams before applying any information.

Secured by Sectigo
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
Support the12volt.com
Top
the12volt.com spacer
the12volt.com spacer