the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
icon

2004 Honda Civic Radio Wiring


Post ReplyPost New Topic
< Prev Topic Next Topic >
tigersnare04 
Member - Posts: 1
Member spacespace
Joined: November 16, 2006
Posted: December 30, 2006 at 6:28 PM / IP Logged  

Can anyone tell me the colors of the 12v switched and ground for a 2004 Honda Civic?

              

KarTuneMan 
Platinum - Posts: 7,056
Platinum spaceThis member has made a donation to the12volt.com. Click here for more info.spaceThis member consistently provides reliable informationspace
Joined: December 14, 2004
Location: Isle Of Man
Posted: December 30, 2006 at 10:43 PM / IP Logged  
+12V DC Battery(Constant)WHITE/ red  10 Amp Fuse box under hood 
Switched AccessoryYellow/red  7.5 Amp Fuse/relay box under dash 
Ground Black  
Illumination RED / black  
Left Front + GREEN/ black  
Left Front - Light green  
Right Front + GREEN/ YELLOW  
Right Front - Gray/red  
Left Rear + Blue/white  
Left Rear - Blue/black  
Right Rear + Pink  
Right Rear - Blue / YELLOW  
2004 Honda Civic Radio Wiring -- posted image. AT SPEAKERS 
Wire FunctionColorNote
Left Front Mid + GREEN/ black GREEN/ YELLOW for Hybrid and Sedan 
Left Front Mid - Light green Gray/red for Hybrid and Sedan 
Left Front Tweeter + GREEN/ black 
Left Front Tweeter - Light green 
Right Front Mid + GREEN/ YELLOW GREEN/ black for Hybrid and Sedan 
Right Front Mid - Gray/red Light green for Hybrid and Sedan 
Right Front Tweeter + GREEN/ YELLOW 
Right Front Tweeter - Gray/red 
nikneymeyer 
Member - Posts: 1
Member spacespace
Joined: January 06, 2007
Posted: January 06, 2007 at 10:23 PM / IP Logged  

I have a 2001 Civic, which from what I've read has the same stereo wiring harness/pinout as the 2004.  Today I installed an aftermarket head unit.  There were four wires on the factory harness that did not correspond to any of the wires on the new HU.  There was a RED / black (illumination, which I gathered from this post), a red (dimmer, which I got from some other message board), plus a yellow/red and a YELLOW /GREEN.  I haven't found anything that these are for.  Currently I have them taped off.

Everything else appears to be wired up correctly.  When I turn the ignition to the acc. position, the needles and odometer display wig out for about 3 seconds, then appear to be fine.  The HU's power button becomes illuminated, but that's all I can get it to do for now.

Is there something I am missing?  I have installed a number of stereos in the past, but the latest model was a 1989 Cutlass Supreme.

Any insight would be greatly appreciated.  Thanks!

--Nik


Sorry, you can NOT post a reply.
This topic is closed.

  Printable version Printable version Post ReplyPost New Topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

  •  
Search the12volt.com
Follow the12volt.com Follow the12volt.com on Facebook
Monday, June 24, 2024 • Copyright © 1999-2024 the12volt.com, All Rights Reserved Privacy Policy & Use of Cookies
Disclaimer: *All information on this site ( the12volt.com ) is provided "as is" without any warranty of any kind, either expressed or implied, including but not limited to fitness for a particular use. Any user assumes the entire risk as to the accuracy and use of this information. Please verify all wire colors and diagrams before applying any information.

Secured by Sectigo
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
Support the12volt.com
Top
the12volt.com spacer
the12volt.com spacer