the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
icon

1987 ford ltd crown vic w/ premium sound


Post ReplyPost New Topic
< Prev Topic Next Topic >
hynch 
Member - Posts: 5
Member spacespace
Joined: May 17, 2009
Location: North Carolina, United States
Posted: May 17, 2009 at 1:48 AM / IP Logged  
I have an 87 Ford LTD CV with the Premium Sound (6 speakers + factory amp) and I am trying to install an aftermarket Pioneer. I was hoping to use the factory speakers and avoid having to rewire if possible. I have a wire harness that I purchased at Walmart. The dash unit powers up fine, but I get no sound on my speakers. I am wondering if it is a ground problem.
Any input would be awesome. :)
i am an idiot 
Platinum - Posts: 13,488
Platinum spaceThis member consistently provides reliable informationspace
Joined: September 21, 2006
Location: Louisiana, United States
Posted: May 17, 2009 at 4:55 AM / IP Logged  
Does the Wal-Mart plug have a blue wire labeled: Power Antenna? If yes, did you connect it to the Blue/White wire of your new deck?
tommy... 
Gold - Posts: 1,901
Gold spacespace
Joined: December 10, 2004
Location: United States
Posted: May 17, 2009 at 10:23 AM / IP Logged  
You replaced factory radio...Everything worked before...? What is the model # off harness you bought...? Did any speakers make a muffled sound when factory radio was installed?
M.E.C.P & First-Class
Go slow and drink lots of water...Procrastinators' Unite...Tomorrow!
Ween 
Platinum - Posts: 1,334
Platinum spacespace
Joined: August 01, 2004
Location: Illinois, United States
Posted: May 17, 2009 at 12:35 PM / IP Logged  

hi,

was there a ring terminal (red wire?) connected to the rear of the factory radio? if so, it is the ground wire for the premium sound amplifier, needs to be connected for the amplifier to power up.

m

hynch 
Member - Posts: 5
Member spacespace
Joined: May 17, 2009
Location: North Carolina, United States
Posted: May 17, 2009 at 12:53 PM / IP Logged  
i am an idiot wrote:
Does the Wal-Mart plug have a blue wire labeled: Power Antenna? If yes, did you connect it to the Blue/White wire of your new deck?
Yes I did. The wire harness connects to a Pioneer specific harness and I checked all the cables to ensure they are paired up correctly.
tommy... wrote:
You replaced factory radio...Everything worked before...? What is the model # off harness you bought...? Did any speakers make a muffled sound when factory radio was installed?
Yes everything worked fine before. The harness is a Metra 80-1770. It was the only one they had that fit a Pioneer wire harness. The speakers make no sound at all.
ween wrote:
was there a ring terminal (red wire?) connected to the rear of the factory radio? if so, it is the ground wire for the premium sound amplifier, needs to be connected for the amplifier to power up.
No, I do not recall a ring terminal.
tommy... 
Gold - Posts: 1,901
Gold spacespace
Joined: December 10, 2004
Location: United States
Posted: May 17, 2009 at 1:10 PM / IP Logged  
The blue wire off of radio is showing 12 volts w/ radio on...? On the black plug in car...How many wires are going into the back of harness{the speaker harness}?
M.E.C.P & First-Class
Go slow and drink lots of water...Procrastinators' Unite...Tomorrow!
tommy... 
Gold - Posts: 1,901
Gold spacespace
Joined: December 10, 2004
Location: United States
Posted: May 17, 2009 at 1:16 PM / IP Logged  

sometimes there is a bad speaker and you dont notice w/ factory...replace stereo w/ after marketand get no sound b/c of bad speaker...you can remove leads one by one untill you get sound or take all of and put pair together... listen...take off... try another pair.

M.E.C.P & First-Class
Go slow and drink lots of water...Procrastinators' Unite...Tomorrow!
hynch 
Member - Posts: 5
Member spacespace
Joined: May 17, 2009
Location: North Carolina, United States
Posted: May 17, 2009 at 3:44 PM / IP Logged  
tommy... wrote:
The blue wire off of radio is showing 12 volts w/ radio on...? On the black plug in car...How many wires are going into the back of harness{the speaker harness}?
There are 5 wires. Speaker Harness.
Upon further inspection there was a ring terminal from the amp. It had slid back behind the dash. I grounded it to the chassis and the speakers "pop" when powering on the dash unit. I assume it is just the amp is firing up. Still no sound though. I am thinking the speakers are wired in an odd way. Gotta love Ford.
i am an idiot 
Platinum - Posts: 13,488
Platinum spaceThis member consistently provides reliable informationspace
Joined: September 21, 2006
Location: Louisiana, United States
Posted: May 17, 2009 at 4:01 PM / IP Logged  
Try connecting one of the aftermarket radios speaker wires to a known good speaker to make sure there is output coming from the deck.
burns25 
Member - Posts: 49
Member spacespace
Joined: March 09, 2005
Location: United States
Posted: May 17, 2009 at 5:06 PM / IP Logged  
That speaker harness you have has the common ground premium system.  Two choices, find the amp and bypass it or run new wires from the speakers.  It's been a while, but I know that on the mustangs the amps are right there by the radio and you can just unhook the output of the amp plug and it is just a 1770 harness.  Truth be told I really can't remember, but it's worth a shot looking for the amp and see if it has the plug.
Page of 2

  Printable version Printable version Post ReplyPost New Topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

  •  
Search the12volt.com
Follow the12volt.com Follow the12volt.com on Facebook
Monday, January 17, 2022 • Copyright © 1999-2022 the12volt.com, All Rights Reserved Privacy Policy & Use of Cookies
Disclaimer: *All information on this site ( the12volt.com ) is provided "as is" without any warranty of any kind, either expressed or implied, including but not limited to fitness for a particular use. Any user assumes the entire risk as to the accuracy and use of this information. Please verify all wire colors and diagrams before applying any information.

Secured by Sectigo
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
Support the12volt.com
Top
the12volt.com spacer
the12volt.com spacer