the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
icon

1996 eclipse rs lights dont turn on


Post ReplyPost New Topic
< Prev Topic Next Topic >
xchrisx 
Copper - Posts: 197
Copper spacespace
Joined: August 19, 2008
Location: Pennsylvania, United States
Posted: September 27, 2011 at 11:22 AM / IP Logged  
I have a 96 Eclipse RS.
I have replaced my headlight switch 3x and all the same problems so I am doubting it is a problem with my switch.
I also tested my bulbs and all the bulbs are working fine when I hook them directly up to a 12v source so I also know it is not my bulbs that are bad.
Background....
A long time ago, my headlights and dash lights just shut off on me when I turned them on. I checked and the fuses were all fine as well as the relay. I tried 3 different headlight switches and they all didn't work in my car but do work in my friends Eclipse so I know the one I currently have is good.
Now, here is the problem...
My headlights will only work when I pull and hold right before the click to high beams, in that position only will both my high beam and low beam lights work and my dash lights as well. It doesn't matter if the switch is turned one or 2 clicks or even off, that is the only time the lights work at all. My taillights wont turn on nor will my license plate light, however my blinkers and hazards still work.(I know they are on the same switch but a different harness so I am assuming we don't need to even discuss that at all, but may be wrong).
So I am trying to see whats going on, maybe if someone can tell me what wire should read what on the headlight switch and the relay wires in the fuse box, that would probably help best....I tested the wires on the fuse box and with the picture attached is what I came up with.
Please help me because I can not figure it out. Again if someone can tell me what wires are supposed to read what and when from both the headlight switch headlight harness and same thing for the wires for the relay under the hood.
Thanks a lot in advance! 1996 eclipse rs lights dont turn on - Last Post -- posted image.
bp
xchrisx 
Copper - Posts: 197
Copper spacespace
Joined: August 19, 2008
Location: Pennsylvania, United States
Posted: September 28, 2011 at 4:22 PM / IP Logged  
I figured it out be looking at my friends headlight switch, apparently one of my wires was put back in the harness in the wrong spot and it was causing all of my problems. I put it in the correct spot and *BAM* everything worked perfect!
bp

Sorry, you can NOT post a reply.
This topic is closed.

  Printable version Printable version Post ReplyPost New Topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

  •  
Search the12volt.com
Follow the12volt.com Follow the12volt.com on Facebook
Monday, September 26, 2022 • Copyright © 1999-2022 the12volt.com, All Rights Reserved Privacy Policy & Use of Cookies
Disclaimer: *All information on this site ( the12volt.com ) is provided "as is" without any warranty of any kind, either expressed or implied, including but not limited to fitness for a particular use. Any user assumes the entire risk as to the accuracy and use of this information. Please verify all wire colors and diagrams before applying any information.

Secured by Sectigo
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
Support the12volt.com
Top
the12volt.com spacer
the12volt.com spacer