the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
icon

tube replacement in pioneer avic


Post ReplyPost New Topic
< Prev Topic Next Topic >
badnews 
Member - Posts: 2
Member spacespace
Joined: March 08, 2006
Location: United States
Posted: March 08, 2006 at 3:11 PM / IP Logged  
Screen on pioneer avic navigation system went black, but faint images are present.  Manual says small fluorescent tube has life of 10,000 hours.  Since system came with used car, I assume that my 10,000 hours are up.  Any advice on replacing the fluorescent tube?  Where can I find a replacement tube?  Thanks for any advice.
badnewsbarrister
mad550 
Copper - Posts: 201
Copper spacespace
Joined: February 23, 2006
Location: Australia
Posted: March 08, 2006 at 3:45 PM / IP Logged  
Best bet would be authorised repair agent but brace yourself its not going to be cheap,  I'm lucky I do my own repair work and the last time I had to replace a cathode tube it was AUD$300 just for the part.
WOW Sight and Sound
Maroochydore
Nothing is impossible!
Do it right the first time or don't do it at all.
Preservedswine 
Member - Posts: 35
Member spacespace
Joined: May 19, 2005
Location: United States
Posted: March 08, 2006 at 7:21 PM / IP Logged  
Wow, that's alot of hours...
Dumb question, have you tried increasing the brightness?
Are all other functions working properly?
badnews 
Member - Posts: 2
Member spacespace
Joined: March 08, 2006
Location: United States
Posted: March 09, 2006 at 7:56 AM / IP Logged  
Brightness control does not make a difference and, based on sound produced by touching various parts of screen, I believe that other functions are working.  10,000 hours seems like a lot, but system came on used car and I have no idea how many hours were logged before I bought the car.  For last year, my son has operated car and was so proud of the system that it was up and operating at all times.  He even had his college roommates sit around in the car watching movies.
badnewsbarrister
neal1154@yahoo. 
Member - Posts: 14
Member spacespace
Joined: March 09, 2006
Posted: March 09, 2006 at 11:01 AM / IP Logged  

the part that you are talking about is the screen correct? this is an LCD display and may not be your problem if you have no display but your unit still functions I can fix this problem just let me know 614-496-1692 Neal

mad550 
Copper - Posts: 201
Copper spacespace
Joined: February 23, 2006
Location: Australia
Posted: March 09, 2006 at 3:43 PM / IP Logged  
back light needs to be looked at,  Viscom brand have a major problem with this too
WOW Sight and Sound
Maroochydore
Nothing is impossible!
Do it right the first time or don't do it at all.

Sorry, you can NOT post a reply.
This topic is closed.

  Printable version Printable version Post ReplyPost New Topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

  •  
Search the12volt.com
Follow the12volt.com Follow the12volt.com on Facebook
Friday, December 2, 2022 • Copyright © 1999-2022 the12volt.com, All Rights Reserved Privacy Policy & Use of Cookies
Disclaimer: *All information on this site ( the12volt.com ) is provided "as is" without any warranty of any kind, either expressed or implied, including but not limited to fitness for a particular use. Any user assumes the entire risk as to the accuracy and use of this information. Please verify all wire colors and diagrams before applying any information.

Secured by Sectigo
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
Support the12volt.com
Top
the12volt.com spacer
the12volt.com spacer