the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
icon

protection mode


Post ReplyPost New Topic
< Prev Topic Next Topic >
garrett12 
Member - Posts: 14
Member spacespace
Joined: June 01, 2010
Location: Virginia, United States
Posted: September 12, 2010 at 6:10 AM / IP Logged  

my amp goes into protect mode as soon as it turns on and stays in that mode... ive tried everything.    it worked fine until i changed the ground wire out to a shorter one, hoping that would eliminate some road noise but that didnt happen. can anyone help me with this problem

i am an idiot 
Platinum - Posts: 13,597
Platinum spaceThis member consistently provides reliable informationspace
Joined: September 21, 2006
Location: Louisiana, United States
Posted: September 12, 2010 at 7:27 AM / IP Logged  

The following link will help you with your Road Noise.  http://bcae1.com/images/rca/temporaryrcashieldrepair.html

As far as the amp being in protect, you need to use a volt meter to make sure the amp is getting a good ground from the new ground point.  Or ground it to the old ground point.  It was a good ground if the amp worked when it was grounded there.

DYohn 
Moderator - Posts: 10,740
Moderator spaceThis member has made a donation to the12volt.com. Click here for more info.spaceThis member has been recognized as an authority in Electrical Theory. Click here for more info.spaceThis member has been recognized as an authority in Mobile Audio and Video. Click here for more info.spacespace
Joined: April 22, 2003
Location: Arizona, United States
Posted: September 12, 2010 at 9:43 AM / IP Logged  

Try disconnecting the speakers and see if the amp will come on.  Also, when you moved the ground, did you make sure the power to the amp was off (fuse pulled) before you started?  If not, the amp could now be toast...

Support the12volt.com
garrett12 
Member - Posts: 14
Member spacespace
Joined: June 01, 2010
Location: Virginia, United States
Posted: September 13, 2010 at 8:27 AM / IP Logged  
yea i had taken all the fuses out when i did it.... ive tried all of that. thank you for the ideas.    i wish i knew a place that would repair it somehow. ive had it for 3 years.   if i cant get it fixed i guess ill buy a new one.
DYohn 
Moderator - Posts: 10,740
Moderator spaceThis member has made a donation to the12volt.com. Click here for more info.spaceThis member has been recognized as an authority in Electrical Theory. Click here for more info.spaceThis member has been recognized as an authority in Mobile Audio and Video. Click here for more info.spacespace
Joined: April 22, 2003
Location: Arizona, United States
Posted: September 13, 2010 at 1:15 PM / IP Logged  

Test the voltage (like was already suggested) and if it's good, sounds like the amp is dead.  Yes there are some plaes that will repair amps if it's worth repairing.  What's te make and model?

Support the12volt.com
i am an idiot 
Platinum - Posts: 13,597
Platinum spaceThis member consistently provides reliable informationspace
Joined: September 21, 2006
Location: Louisiana, United States
Posted: September 13, 2010 at 3:40 PM / IP Logged  

Am I invisible again?

DYohn 
Moderator - Posts: 10,740
Moderator spaceThis member has made a donation to the12volt.com. Click here for more info.spaceThis member has been recognized as an authority in Electrical Theory. Click here for more info.spaceThis member has been recognized as an authority in Mobile Audio and Video. Click here for more info.spacespace
Joined: April 22, 2003
Location: Arizona, United States
Posted: September 13, 2010 at 4:55 PM / IP Logged  
i am an idiot wrote:

Am I invisible again?

Nope.  I fixed my post.  :)

Support the12volt.com
i am an idiot 
Platinum - Posts: 13,597
Platinum spaceThis member consistently provides reliable informationspace
Joined: September 21, 2006
Location: Louisiana, United States
Posted: September 13, 2010 at 5:26 PM / IP Logged  
I knew YOU could see me. 
DYohn 
Moderator - Posts: 10,740
Moderator spaceThis member has made a donation to the12volt.com. Click here for more info.spaceThis member has been recognized as an authority in Electrical Theory. Click here for more info.spaceThis member has been recognized as an authority in Mobile Audio and Video. Click here for more info.spacespace
Joined: April 22, 2003
Location: Arizona, United States
Posted: September 13, 2010 at 5:56 PM / IP Logged  

i am an idiot wrote:
I knew YOU could see me. 

Did you say something??  protection mode -- posted image.

Support the12volt.com
i am an idiot 
Platinum - Posts: 13,597
Platinum spaceThis member consistently provides reliable informationspace
Joined: September 21, 2006
Location: Louisiana, United States
Posted: September 13, 2010 at 7:35 PM / IP Logged  
Apparently not.
Page of 2

  Printable version Printable version Post ReplyPost New Topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

  •  
Search the12volt.com
Follow the12volt.com Follow the12volt.com on Facebook
Wednesday, November 30, 2022 • Copyright © 1999-2022 the12volt.com, All Rights Reserved Privacy Policy & Use of Cookies
Disclaimer: *All information on this site ( the12volt.com ) is provided "as is" without any warranty of any kind, either expressed or implied, including but not limited to fitness for a particular use. Any user assumes the entire risk as to the accuracy and use of this information. Please verify all wire colors and diagrams before applying any information.

Secured by Sectigo
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
Support the12volt.com
Top
the12volt.com spacer
the12volt.com spacer