the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
icon

Viper 5301 + Idatalink ADS-AL-CA on Q50


Post ReplyPost New Topic
< Prev Topic Next Topic >
kreg357 
Platinum - Posts: 7,493
Platinum spaceThis member has made a donation to the12volt.com. Click here for more info.spaceThis member has been recognized as an authority in Electrical Theory. Click here for more info.spaceThis member has been recognized as an authority in Mobile Security and Convenience. Click here for more info.spacespace
Joined: January 30, 2009
Location: New York, United States
Posted: November 01, 2016 at 7:47 PM / IP Logged Link to Post Post Reply Quote kreg357

I would follow the iDatalink install guide for all wiring.  The Fortin guide is for their bypass module.  Don't try to combine the two.

You can do a Factory Reset on the bypass module without losing the NI3 flash.  Next set the Installation Mode and then program to the vehicle.  Are you sure the bypass module has the DBI flavor of firmware?

Soldering is fun!
vitaliyk 
Member - Posts: 21
Member spacespace
Joined: October 14, 2016
Location: Ontario, Canada
Posted: November 01, 2016 at 9:17 PM / IP Logged Link to Post Post Reply Quote vitaliyk
Would you please comment ACC+ wiring and red light on ADS?
2015 Infiniti Q50 Limited Edition 3.7L
vitaliyk 
Member - Posts: 21
Member spacespace
Joined: October 14, 2016
Location: Ontario, Canada
Posted: November 07, 2016 at 11:03 AM / IP Logged Link to Post Post Reply Quote vitaliyk
What does it mean "KEYS REQUIRED FOR PROGRAMMING 1"? "KEYS REQUIRED FOR INSTALLATION 0"?
2015 Infiniti Q50 Limited Edition 3.7L
smokeman1 
Platinum - Posts: 1,588
Platinum spaceThis member has made a donation to the12volt.com. Click here for more info.spaceThis member has been recognized as an authority in Mobile Security and Convenience. Click here for more info.spacespace
Joined: September 14, 2009
Location: Wisconsin, United States
Posted: November 07, 2016 at 2:18 PM / IP Logged Link to Post Post Reply Quote smokeman1
WOW!!! I would recommend taking this project to a pro.
When all else fails, Read the Instructions
Support the12volt.com Make a Donation
vitaliyk 
Member - Posts: 21
Member spacespace
Joined: October 14, 2016
Location: Ontario, Canada
Posted: November 13, 2016 at 8:30 AM / IP Logged Link to Post Post Reply Quote vitaliyk
Any useful information?
I'm not a pro with remotes required bypass but I definitely can do proper wiring. If I ask questions here I count on help from pro and from non-pro. We all do something for the first time. Besides I just like to do such staff by myself.
2015 Infiniti Q50 Limited Edition 3.7L
vitaliyk 
Member - Posts: 21
Member spacespace
Joined: October 14, 2016
Location: Ontario, Canada
Posted: November 13, 2016 at 9:02 AM / IP Logged Link to Post Post Reply Quote vitaliyk
Any help?
Here is what I have:
ADS-AL-CA programmed with DBI-AL(DL)-NI3-EN for Q50 and 5301
Here is info from the screen I received from seller.
Device type: Remote Starter
Make and model: Viper - 5301 Responder LE
Installation mode: DBI
Firmware: DL-NI3
Remote starter system 5301-2LE (4204 main module)
Connected according to diagram #4. I just moved few wires to J/B M133 connector as I'm going to place it behind the wheel.
INSTALLATION MODE SELECTION: Set ADS to data mode.
MODULE PROGRAMMING PROCEDURE success.
Doors lock/unlock does not work. Light flashes and I see pulses on remote outputs but locks do not react.
When push start button the ignition turns on, LED on bypass is flashing green. Then at the moment Viper activate start outputs the LED turns to solid RED. After few second system turns OFF. It repeats this 3 times. After 3-d time it goes off permanently with alarm on remote fob and "incorrect key ID" on the screen.
What did I miss?
Could it be because the bypass programmed for 5301 but actual module is 4204? Which model should be picked from ADS programming menu if 4204 is not listed? Use "Others"?
Would really appreciate real help.
2015 Infiniti Q50 Limited Edition 3.7L
vitaliyk 
Member - Posts: 21
Member spacespace
Joined: October 14, 2016
Location: Ontario, Canada
Posted: November 13, 2016 at 8:11 PM / IP Logged Link to Post Post Reply Quote vitaliyk
Looks like Idatalink read this thread as they posted updated wiring diagram with accessory relay control connected. I wonder this this the only mistake they made as I still cannot make it work.
2015 Infiniti Q50 Limited Edition 3.7L
vitaliyk 
Member - Posts: 21
Member spacespace
Joined: October 14, 2016
Location: Ontario, Canada
Posted: November 26, 2016 at 6:42 AM / IP Logged Link to Post Post Reply Quote vitaliyk
Are any professionals here to help me with this issue?
I reconnect for W2W, switch ADS to hardwire mode. Nothing is changed.
After 3 times it rties to start is says "Incorrect key ID". Looks like anything controlled over CAN is not working.
Please help.
2015 Infiniti Q50 Limited Edition 3.7L
vitaliyk 
Member - Posts: 21
Member spacespace
Joined: October 14, 2016
Location: Ontario, Canada
Posted: November 29, 2016 at 5:04 AM / IP Logged Link to Post Post Reply Quote vitaliyk
Anyone? Any suggestions? What did I miss?
I would newer believe nobody installed such combination. Is all information is top secret? Then please answer in PM.
2015 Infiniti Q50 Limited Edition 3.7L
vitaliyk 
Member - Posts: 21
Member spacespace
Joined: October 14, 2016
Location: Ontario, Canada
Posted: July 04, 2017 at 10:28 AM / IP Logged Link to Post Post Reply Quote vitaliyk
Here is the update.
Idatalink released new firmware wich solved "Incorrect key ID" issue. Now everything is fine exept take over procedure.
After “start” button is pressed on Viper’s remote the GREEN LED on ADS module blinks slow twice then RED LED during the crank and back to series of two green blinks.
The GREEN LED continues slow blink 2x..2x..2x.. until door unlock( not opened yet)
As door is unlocked the GREEN LED starts flashing rapidly (like tachometer signal)
After door opened and closed no any visible actions. Orange LED on PTS button is OFF.
As brake pedal is pressed the Orange LED on PTS button switched to ON, “flat tire” alarm appears for couple of seconds.
Takeover procedure goes normal after this. LED on ADS module turn to OFF.
In Doc. No.:32193, page 26 step 3 “Wait for the ORANGE LED indicator of the push button to turn on.”
It never goes on unless brake pedal or PTS is pressed.
“Failure to follow procedure may result in vehicle displaying CHECK ENGINE or TIRE PRESSURE error messages.”
“TIRE PRESSURE error messages” I have every time I press the brake pedal or PTS after remote start as step 3 cannot be completed.
Any ideas what can be done to solve this issue?
2015 Infiniti Q50 Limited Edition 3.7L
Page of 2

If you wish to post a reply to this topic, you must first login.
If you are not already registered, you must first register.

  Printable version Printable version Post ReplyPost New Topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

  •  
Search the12volt.com
Follow the12volt.com Follow the12volt.com on Facebook
Sunday, October 24, 2021 • Copyright © 1999-2021 the12volt.com, All Rights Reserved Privacy Policy & Use of Cookies
Disclaimer: *All information on this site ( the12volt.com ) is provided "as is" without any warranty of any kind, either expressed or implied, including but not limited to fitness for a particular use. Any user assumes the entire risk as to the accuracy and use of this information. Please verify all wire colors and diagrams before applying any information.

Secured by Sectigo
the12volt.com spacer
the12volt.com spacer
the12volt.com spacer
Support the12volt.com
Top
the12volt.com spacer
the12volt.com spacer